Microsoft releases Security Update for Skype for Business 2016 (KB2910994) 64-Bit Edition

This security update resolves vulnerabilities in Skype for Business 2016 that could allow remote code execution if a user opens a specially crafted document or goes to an untrusted webpage that contains embedded OpenType fonts. To learn more about the vulnerabilities, see Microsoft Security Bulletin MS15-097.

KB:

Fixes:

This security update also contains fixes for the following nonsecurity issues:

  • Invalid speech signal level when you convert a stereo microphone array to monaural. This results in noise or a full echo.
  • When you try to start the co-edit option from sharing, you receive the following error message: “Operating system is not presently configured to run this application.”
  • No mirrors occur when you open Skype Meeting in Microsoft Outlook for some languages.
  • The co-author option doesn’t work.
  • All instances of “co-edit” are renamed “co-author.”

Download:

  • 32-bit | 64-bit
  • Version: 1.0
  • File Name: lync2016-kb2910994-fullfile-x64-glb.exe | lync2016-kb2910994-fullfile-x86-glb.exe
  • Date Published: 9/28/2015
  • File Size: 65.4 MB

4 Comments

  1. Yitzhak

    I have Skype4B 2016 installed on my machine. Its version 16.0.4266.1003.
    While trying to install that security update: lync2016-kb2910994-fullfile-x64-glb.exe, I am getting the following error message:

    Security Update for Skype for Business 2016 (KB2910994) 64-Bit Edition
    —————————
    There are no products affected by this package installed on this system.

    Reply
    1. Guy Bachar (Post author)

      Are you running the O365 (Click to Run) Version or the MSDN version?

      Reply
  2. Yitzhak

    The original installation en_office_professional_plus_2016_x86_x64_dvd_6962141.iso came from the MSDN. 64-bit version was installed.

    Reply
  3. Yitzhak

    It seems that I discovered what prevents the update to be installed.
    The installation package comes compressed with the XML file inside for version checking.
    That XML file contains the following fragment below.
    It seems that the expected Skype4B version to be updated is 16.0.4266.1001.
    Though my machine has Skype4B 16.0.4266.1003 version.
    Go figure…

    {90160000-012B-0409-1000-0000000FF1CE}
    16.0.4266.1001
    1033
    1033
    {00160000-012B-0000-1000-0000000FF1CE}

    Reply

Leave a Comment

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.